More

Displaying X, Y coordinates on ArcGIS not working


I am trying to geocode some coordinates I have from my Excel sheet onto ArcGIS but everytime I do so, it doesn't show up on the screen. When I right click on the sheet layer to see where it went, it shows my points as this:

Here is also a photo of what my attribute table looks like:

I have tried multiple times removing it, restarting ArcMap and but this still happens. Before, it used to display all my longitude points as 0, but since then I have tried tweaking around on my Excel sheet.

This has never happened before. Could it have something to do with ArcMap not being able to read the decimal placements since they are not aligned perfectly.

I also made sure to pick my X value to be my longitude, and Y value as latitude.

Can anyone explain why this is happening?


I had the same problem and simply convert.xlsxto.csvonly helped to display the x coordinate. I used the table to table file to create a new table from the.csvfile and define the field type to be numeric. After that it worked. To me it seems to be more of an excel problem rather than an ArcGIS 10.3 problem…


So turns out when I convert my excel file to a csv file it finally worked.

I guess it won't work on a newer version of excel (on a Mac).


It looks like your X (Longitude) is coming over as an integer, thus ignoring all the decimals while the Y is coming in correct.

When teaching many students using excel would hit a space in a cell making the field come over into ArcMap as a text, preventing you from even being able to plot the points. The CSV option gets around this by stripping away the formatting.


Watch the video: Add GPS coordinates into Arcmap (October 2021).